Product Availability Status

Australia and New Zealand product availability

If you are experiencing an issue with an Equifax service that you do not see posted on this site, please contact the Equifax IT Service Desk on (AUS) 1800 245 744 or +61 2 7256 4393 / (NZ) 0800 378 329 or +64 9 886 6603

Please click here for help managing your subscription and FAQs

Recent Incidents

Property-Valuation - Start [04:00] [AM] [AEDT] [23/08] - [INC7117095]

Resolved

Start:
04:00 AM AEDT 23/08/2026


End:
10:00 AM AEDT 23/08/2026


Latest update:
Service is now restored. We appreciate your patience and we apologies if you were affected by this incident.
If you are still experiencing any impacts from this incident, please contact the Equifax Service Desk on:

esd@equifax.com
Australia Toll Free: 1800 245 744. For outside Australia: +61 2 7256 4393
New Zealand Toll Free: 0800 378 329. For outside New Zealand: +64 9 886 6603

We will continue to monitor the system closely and will analyze the incident's cause through a detailed Post Incident Review.



Main affected services:
Property-Valuation

How this might have affected you:
Property Valuation AWS_AVM & PP Report FULL REPORT was not available as Property-Valuation was Hard Down.



Now All Services are Operational.
Posted Aug 23, 2026 - 10:18 AEST

Investigating

Start:
04:00 AM AEDT 23/08/2026

Main affected services:
Property-Valuation

How this may affect you:
Property Valuation AWS_AVM & PP Report FULL REPORT not available as Property-Valuation is Hard Down.

Latest update:
Team is currently investigating and working on a resolution.




Steps we are taking to restore the service/s:
Technical team is investigating.

Actions you may need to take:
No action is required from you.

Next communication:
Within 30 minutes, or as soon as investigations provide more clarity.
Posted Aug 23, 2026 - 07:13 AEST
This incident affected: Property Valuation (IQ Connect).