Product Availability Status

Australia and New Zealand product availability

If you are experiencing an issue with an Equifax service that you do not see posted on this site, please contact the Equifax IT Service Desk on (AUS) 1800 245 744 or +61 2 7256 4393 / (NZ) 0800 378 329 or +64 9 886 6603

Please click here for help managing your subscription and FAQs

Recent Incidents

3rd Party - DVS Australian Electoral Commission

Resolved

Dear Customer,

The service impacting incident reported by our 3rd Party partner has now been resolved. Please see below for further information.

3rd Party Company: DVS
Incident Reference: INC7087879
Start time: 14:43 23/06/26
End time: 10:30 24/06/26
Please note that the above times are based on the current Sydney timezone

If you are still experiencing any impacts from this incident, please contact the Equifax Service Desk on:
esd@equifax.com
Australia Toll Free: 1800 245 744. For outside Australia: +61 2 7256 4393
New Zealand Toll Free: 0800 378 329. For outside New Zealand: +64 9 886 6603

Regards,
Equifax Service Desk.
Posted Jun 24, 2026 - 10:44 AEST

Investigating

Dear Customer,

One of our 3rd Party partners has reported a service impacting incident on the components listed below. Further updates will be provided through notifications or can be viewed by accessing the Equifax Status Page portal.

3rd Party Company: DVS
Incident Reference: INC7087879
Start time: 14:43 23/06/26
Service status: Degraded performance
Please note that the above times are based on the current Sydney timezone

Regards,

Equifax Service Desk.
Posted Jun 23, 2026 - 16:08 AEST
This incident affected: IDMatrix - 3rd Party (DVS - Australian Electoral Commission).