Product Availability Status

Australia and New Zealand product availability

If you are experiencing an issue with an Equifax service that you do not see posted on this site, please contact the Equifax IT Service Desk on (AUS) 1800 245 744 or +61 2 7256 4393 / (NZ) 0800 378 329 or +64 9 886 6603

Please click here for help managing your subscription and FAQs

Recent Incidents

Commercial and Consumer Bureau Customer Test Area (CTA)

Scheduled for Jul 1, 22:00 AEST  -  Jul 2, 03:00 AEST

Update

UPDATE: Details of this maintenance have changed. Please see below for new details.

Dear Customer,

As part of our technology infrastructure move to Cloud, we will be performing a planned upgrade to our Commercial and Consumer Bureau Customer Test Area (CTA).

Maintenance Reference: CHG1224600
Start Time:01/07/26 22:00
End Time: 02/07/26 03:00
Please note that the above times are based on the current Sydney timezone

How This Affects You
We aim to make the transition as seamless as possible to minimise impact on the CTA environment.
Impacted Services: Core Bureau / Pegasus Customer Testing Area (CTA)
No Action Required: Your data, configurations, and settings will remain unaffected.

Support
Should you or your IT support team have any inquiries, please contact the IT Service Desk on +61 2 7256 4393 or 1800 245 744 or by emailing esd@equifax.com.

We appreciate your cooperation and understanding as we continue to improve the security and reliability of our platforms.
Posted Jun 23, 2026 - 12:13 AEST

Scheduled

Dear Customer,

As part of our technology infrastructure move to Cloud, we will be performing a planned upgrade to our Commercial and Consumer Bureau Customer Test Area (CTA).

Maintenance Window
To minimise impact on your testing activities, this work is scheduled during our standard maintenance window:

Maintenance Reference: CHG1206241
Start Time: 17/06/26 22:00
End Time: 18/06/26 01:00
Please note that the above times are based on the current Sydney timezone

How This Affects You
We aim to make the transition as seamless as possible to minimise impact on the CTA environment.
Impacted Services: Core Bureau / Pegasus Customer Testing Area (CTA)
No Action Required: Your data, configurations, and settings will remain unaffected.

Support
Should you or your IT support team have any inquiries, please contact the IT Service Desk on +61 2 7256 4393 or 1800 245 744 or by emailing esd@equifax.com.

We appreciate your cooperation and understanding as we continue to improve the security and reliability of our platforms.

Regards,
Equifax Service Desk
Posted Jun 12, 2026 - 16:08 AEST
This scheduled maintenance affects: Business Name Store (API Connect, IQ Connect), CCR Portal (IQ Connect), Company File (API Connect, IQ Connect), CR Data Capture (Standalone (API)), Debtor IQ (Standalone (WEB)), Equifax Apply (API Connect, Cloud API, IQ Connect), and Trading History (API Connect, IQ Connect).