If you are experiencing an issue with an Equifax service that you do not see posted on this site, please contact the Equifax IT Service Desk on (AUS) 1800 245 744 or +61 2 7256 4393 / (NZ) 0800 378 329 or +64 9 886 6603
Please click here for help managing your subscription and FAQs
Latest update: Service is now restored. We appreciate your patience and we apologise if you were affected by this incident. If you are still experiencing any impacts from this incident, please contact the Equifax Service Desk on:
esd@equifax.com Australia Toll Free: 1800 245 744. For outside Australia: +61 2 7256 4393 New Zealand Toll Free: 0800 378 329. For outside New Zealand: +64 9 886 6603
We will continue to monitor the system closely and will analyse the incident's cause through a detailed Post Incident Review.
Main affected services: Visual CBO
Latest update: services has been restored
Actions you may need to take:
No action is required from you.
Posted Jun 28, 2026 - 06:12 AEST
Update
We are continuing to investigate this issue.
Posted Jun 28, 2026 - 06:01 AEST
Investigating
Start: 01:10 AM AEDT 28/06/26
Main affected services: Visual CBO
How this may affect you: Service Disruption
Latest update: The technical teams are actively working on a solution.
Actions you may need to take:
No action is required from you.
Next communication: Within 30 minutes, or as soon as investigations provide more clarity.
Posted Jun 28, 2026 - 03:05 AEST
This incident affected: Company Beneficial Ownership (API Connect, IQ Connect).