If you are experiencing an issue with an Equifax service that you do not see posted on this site, please contact the Equifax IT Service Desk on (AUS) 1800 245 744 or +61 2 7256 4393 / (NZ) 0800 378 329 or +64 9 886 6603
Please click here for help managing your subscription and FAQs
Latest update: Service is now restored. We appreciate your patience and we apologies if you were affected by this incident. If you are still experiencing any impacts from this incident, please contact the Equifax Service Desk on:
esd@equifax.com Australia Toll Free: 1800 245 744. For outside Australia: +61 2 7256 4393 New Zealand Toll Free: 0800 378 329. For outside New Zealand: +64 9 886 6603
We will continue to monitor the system closely and will analyze the incident's cause through a detailed Post Incident Review.
Main affected services: All Impacted Services are back to normal.
How this might have affected you: Degraded performance on multiple applications.
Instructions for failed transactions: Please Re-Try all failed transactions
Steps we took to restore the services:
06:20 AM AEST 20/08/2026: Our Scheduled maintenance took longer than expected time. All Services are back to normal now.
Posted Aug 20, 2026 - 07:17 AEST
Investigating
Start: 06:00 AM 20/08/2026
Main affected services: Multiple Services
How this may affect you: Multiple Services degradation
Latest update: Scheduled maintenance is taking a few minutes longer than expected. We are in the final stages and will share an update as soon as we are back online.
Steps we are taking to restore the service/s:
06:00 AM 20/08/2026: Our Technical Team is working on the maintenance.
Actions you may need to take:
No action is required from you.
Next communication: Within 30 minutes, or as soon as investigations provide more clarity.
Posted Aug 20, 2026 - 06:11 AEST
This incident affected: Standard Business Report NZ (API Connect, IQ Connect), ASIC On File (IQ Connect), Bankruptcy Register (IQ Connect), Company Beneficial Ownership (API Connect, IQ Connect), Company File (API Connect, IQ Connect), eTrace (IQ Connect, Standalone (API)), Fit2Work (Standalone (WEB)), Modern Fraudcheck (API Connect, Cloud API), IDMatrix (API Connect, IQ Connect), Consumer Report NZ (API Connect, IQ Connect), PPSR (API Connect, IQ Connect), Trading History (API Connect, IQ Connect), Advanced Business Reports NZ (API Connect, IQ Connect), and ID Plus NZ (IQ Connect).